# US 9,923,852 B2 · Systems and methods for collation, translation, and analysis of passively created digital interaction and relationship data

> Agents: this data is available as JSON from the patentgrep API and MCP server — see https://patentgrep.com/llms.txt

- Number: US 9,923,852 B2
- Document ID: US9923852B2
- Status: Granted
- Kind: B2
- Application number: 14/606,990
- Filed: 2015-01-27
- Published: 2015-05-21
- Granted: 2018-03-20
- Earliest claimed: 2010-10-26
- Assignees: DataHug
- Applicants: Datahug Limited
- Inventors: Ray Smith; Connor Murphy
- Web page: https://patentgrep.com/patent/US9923852B2

## CPC

- H04L 51/216: Handling conversation history, e.g. grouping of messages in sessions or threads
- G06F 16/248: Presentation of query results
- G06Q 10/107: Computer-aided management of electronic mailing [e-mailing]
- H04L 67/535: {Tracking the activity of the user (network monitoring arrangements H04L43/00; recording of computer activity G06F11/34)}
- H04L: TRANSMISSION OF DIGITAL INFORMATION, e.g. TELEGRAPHIC COMMUNICATION (arrangements common to telegraphic and telephonic communication H04M)
- G06F: ELECTRIC DIGITAL DATA PROCESSING (computer systems based on specific computational models G06N)
- G06Q: INFORMATION AND COMMUNICATION TECHNOLOGY [ICT] SPECIALLY ADAPTED FOR ADMINISTRATIVE, COMMERCIAL, FINANCIAL, MANAGERIAL OR SUPERVISORY PURPOSES; SYSTEMS OR METHODS SPECIALLY ADAPTED FOR ADMINISTRATIVE, COMMERCIAL, FINANCIAL, MANAGERIAL OR SUPERVISORY PURPOSES, NOT OTHERWISE PROVIDED FOR

## Abstract

A computer readable medium containing executable instructions that when executed perform a method of generating relationship data, the method comprising: accessing an interaction database, wherein the interaction database comprises a record of exchanges between two or more users of a digital communication system, and wherein the exchanges occurred on the digital communication system; obtaining one or more characteristics of one or more exchanges of the two or more users, wherein the one or more characteristics are stored in the interaction database and wherein the data is obtained through a direct internet access protocol; and generating relationship data by analyzing the one or more characteristics.

## Claims

### Claim 1

A non-transitory computer readable medium containing executable instructions that when executed perform a method of generating relationship data, comprising:
accessing an interaction database, wherein the interaction database include data associated with e-mail exchanges between two users of an e-mail system and at least one other digital communication medium wherein the at least one other digital communication medium is selected from a group consisting of calendar, instant messaging, SMS, and phone;
obtaining an interaction characteristic between the two users, wherein the interaction characteristic is based on a number of the e-mail exchanges between the two users of the e-mail system including interaction volume between the two users of the e-mail system and further based on the at least one other digital communication medium, and wherein the interaction characteristic is stored in the interaction database, and wherein the interaction characteristic comprises a ratio of source to target versus target to source interactions;
generating relationship data by analyzing the interaction characteristic;
determining a relationship strength between the two users based on the number of e-mail exchanges between the two users; and
providing a display of the relationship data for a user interface.

### Claim 2 (depends on 1)

The non-transitory computer readable medium of claim 1, further comprising populating the interaction database, wherein populating the interaction database comprises monitoring e-mail exchanges on the e-mail system and extracting relevant e-mail exchanges.

### Claim 3 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein providing a display of the relationship data for a user interface comprises providing a graphical representation of the relationship strength of the two users.

### Claim 4 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the interaction characteristic comprises at least one selected from the group consisting of interaction frequency, interaction type, and number of communication participants.

### Claim 5 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the interaction characteristic comprises at least one selected from the group consisting of a time since a first interaction and a time since a last interaction between the two users.

### Claim 6 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the interaction characteristic comprises a time between interactions.

### Claim 7 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein providing a display of the relationship data for a user interface comprises providing a summary of an end users connections for a period of time.

### Claim 8 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein providing a display of the relationship data for a user interface comprises providing a list of the most contacted individuals or companies over a period of time.

### Claim 9 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein providing a display of the relationship data for a user interface comprises providing an activity status over a period of time.

### Claim 10 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the data associated with the e-mail exchanges between the two users of the e-mail system is obtained from a mail server, mail archives, and a log file.

### Claim 11 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the data associated with the e-mail exchanges between the two users of the e-mail system is obtained from a spam filtering system based e-mail headers.

### Claim 12 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the data associated with the e-mail exchanges between the two users of the e-mail system is obtained from an e-mail field selected from a group consisting of SMTP, IMAP4, POP3, MIME, RFC 2046, RFC 2822, RFC 3156, and RFC 5322.

### Claim 13 (depends on 1)

The non-transitory computer readable medium of claim 1, wherein the strength of the relationship is further based on intimacy of conversations, frequency of communications, and historical age of the relationship.

### Claim 14

A method of processing relationship data in a server, the method comprising:
receiving, at the server data, interaction data associated with a characteristic of e-mail exchanges between two users of an e-mail system, wherein the interaction data is further associated with at least one other digital communication medium wherein the at least one other digital communication medium is selected from a group consisting of calendar, instant messaging, SMS, and phone, wherein the interaction data is transferred to the server from an interaction database, and wherein the interaction database is populated through a direct internet access protocol, wherein the interaction data associated with the characteristic of the e-mail exchanges between the two users of the e-mail system comprises interaction volume between the two users of the e-mail system and a ratio of source to target versus target to source interactions;
transferring from the server the interaction data to a processor for generating relationship data by analyzing the characteristic of the e-mail exchanges between the two users of the e-mail system and further by analyzing the interaction data associated with the at least one other digital communication medium, and wherein the analyzing the characteristic of the e-mail exchanges between the two users of the e-mail system comprises determining a relationship strength of the two users based on a number of e-mail exchanges between the two users; and
displaying the relationship data on a user interface.

### Claim 15 (depends on 14)

The method of claim 14, wherein the interaction database is populated by monitoring e-mail exchanges and extracting relevant e-mail exchanges.

### Claim 16 (depends on 14)

The method of claim 14, wherein the user interface comprises a graphical representation of the relationship strength of the two users.

### Claim 17 (depends on 14)

The method of claim 14, wherein the characteristic of the e-mail exchanges between the two users of the e-mail system comprises at least one selected from the group consisting of interaction frequency, interaction type, number of communication participants.

### Claim 18 (depends on 14)

The method of claim 14, wherein the characteristic of the e-mail exchanges between the two users of the e-mail system comprises at least one selected from the group consisting of a time since a first interaction and a time since a last interaction.

### Claim 19 (depends on 14)

The method of claim 14, wherein the characteristic of the e-mail exchanges between the two users of the e-mail system comprises a time between interactions.

### Claim 20 (depends on 14)

The method of claim 14, wherein the interaction data associated with the characteristic of the e-mail exchanges between the two users of the e-mail system is obtained from a mail server, mail archives, and a log file.

### Claim 21 (depends on 14)

The method of claim 14, wherein the interaction data associated with the characteristic of the e-mail exchanges between the two users of the e-mail system is obtained from a spam filtering system based e-mail headers.

### Claim 22 (depends on 14)

The method of claim 14, wherein the interaction data associated with the characteristic of the e-mail exchanges between the two users of the e-mail system is obtained from an e-mail field selected from a group consisting of SMTP, IMAP4, POP3, MIME, RFC 2046, RFC 2822, RFC 3156, and RFC 5322.

### Claim 23 (depends on 14)

The method of claim 14 further comprising determining a strength of the relationship data based on intimacy of conversations, frequency of communications, and historical age of the relationship.
