Key management for secure communication
AssigneeTelefonaktiebolaget L M Ericsson (publ)
InventorsRolf Blom, Yi Cheng, Fredrik Lindholm, John Mattsson, Mats Naslund, Karl Norrman
Life of this patent
Estimating the term…
Loading patent…
AssigneeTelefonaktiebolaget L M Ericsson (publ)
InventorsRolf Blom, Yi Cheng, Fredrik Lindholm, John Mattsson, Mats Naslund, Karl Norrman
Estimating the term…
A method and arrangement is disclosed for managing session keys for secure communication between a first and at least a second user device in a communications network. The method is characterized being independent of what type of credential each user device implements for security operations. A first user receives from a first key management server keying information and a voucher and generates a first session key. The voucher is forwarded to at least a responding user device that, with support from a second key management server communicating with the first key management server, resolves the voucher and determines a second session keys. First and second session keys are, thereafter, used for secure communication. In one embodiment the communication traverses an intermediary whereby first and second session keys protect communication with respective leg to intermediary.
A method for establishing secure communication between communication devices in a communications network, the method comprising:
A first key management apparatus, the first key management apparatus comprising:
A method for establishing secure communication between parties in a network, comprising:
Dependencies are inferred from the claim text.
From the US filing history. Foreign family members aren’t listed.
Drawings are temporarily unavailable. Open the PDF at USPTO
Key establishment, i.e. cryptographic processes or cryptographic protocols whereby a shared secret becomes available to two or more parties, for…:…
Key distribution or management, e.g. generation, sharing or updating, of cryptographic keys or passwords: generation of secret information…
For supporting key management in a packet data network: for key exchange, e.g. in peer-to-peer networks
For supporting key management in a packet data network: for key distribution, e.g. centrally by trusted party
About 3 years 2 months of term left · ends 22 Dec 2029 (estimated)
This application is a 35 U.S.C. 371 National Phase Application from PCT/SE2007/050927, filed Nov. 30, 2007, and designating the United States.
The invention is in the field of establishing secure communication between end points. In particular, the invention eliminates requirement that both end points use same type of basic credential.
Many access technologies such as GSM, WCDMA, WLAN, WiMAX provide basic security for the first hop, i.e., communication between the user device and an access point of the network. The communication may use layer 2 or layer 3 in the protocol stack. SRTP (RFC3711) and MIKEY (RFC3830) are examples of protocols for media security and key management. MIKEY can be based on both pre-shared keys and PKI. Moreover, MIKEY can be integrated into session set-up signalling (SIP or RTSP) using RFC4567.
FIG. 1 illustrates prior art deployment of GBA/GAA through an authentication proxy 160 acting as a Network Application Function NAF against the GBA/GAA infrastructure.
FIG. 2 illustrates basic elements of an IMS core network CN subsystem and connection to application server 210.
FIG. 3 is a diagram for describing a first embodiment.
The following description sets forth specific details, such as particular embodiments, procedures, techniques, etc. for purposes of explanation and not limitation. In some instances, detailed descriptions of well known methods, interfaces, circuits, and devices are omitted so as not obscure the description with unnecessary detail. Moreover, individual blocks are shown in some of the drawings. It will be appreciated that the functions of those blocks may be implemented using individual hardware circuits, using software programs and data, in conjunction with a suitably programmed digital microprocessor or general purpose computer, using application specific integrated circuitry, and/or using one or more digital signal processors.
For the purpose of illustration of management of security keys, 3GPP GBA/GAA architecture will be used. However, it is readily understood from the description that any other method for management of security keys may be used that provides for the generation of a shared key between a user UE and an application server, e.g. NAF 160. For example, a UE supporting PKI based credentials could use TLS to create a shared key with the application server. In a username/password based architecture, the PKCS#5 standard could be used to establish a shared key, etc, etc.
FIG. 1 illustrates prior art deployment of GBA/GAA through an authentication proxy 160 acting as a Network Application Function NAF against the GBA/GAA infrastructure. A generic Bootstrapping Server Function 110 BSF and a User Equipment 101 UE mutually authenticates using the UMTS AKA protocol. UE communicates with BSF over an interface 120 Ub. UE and a Home Subscriber System 130 (HSS) shares a key that is basis for HSS to generate an authentication vector provided to BSF over interface 170 Zh. According to the AKA protocol, BSF sends to UE a challenge and UE returns a response to BSF. Authentication is verified by BSF comparing the UE response with an expected response as provided by HSS. Successful authentication initiates at BSF and UE generation of a shared key Ks. BSF stores the key Ks and associated reference B-TID. The reference B-TID and other data, such as a key lifetime, are thereafter provided to UE in a completion message. A Subscriber Locator Function 140 SLF is queried by the BSF over interface 191 Dz in conjunction with the Zh interface operation to get the name of the HSS containing the required subscriber specific data. UE may connect simultaneously to at least one Application Server AS 150_n through a Network Application Function authentication proxy NAF 160. The connection comprises a first step of authentication between UE and NAF. Thereby, UE provides the reference B-TID to NAF that, using B-TID, requests a key (Ks_NAF) from BSF over interface 190 Zn. The key Ks_NAF is derived from the key Ks. The same key may be derived at UE. Authentication is thereafter, made based on the derived key Ks_NAF. The communication between UE and NAF is over an interface Ua 180.