Provisioning server enhancement
AssigneeMediaOne Group, Inc.
InventorBruce F. Bahlmann
Life of this patent
Estimating the term…
Loading patent…
AssigneeMediaOne Group, Inc.
InventorBruce F. Bahlmann
Estimating the term…
An enhanced provisioning server and method of operating a provisioning server that allow for network lease customization for client groups and individual clients. The enhancement also provides a standard interface for exchanging the client lease customization information, a method for maintaining a one lease per client association when clients roam from network to network, and a method for transitioning all of the leases associated with one network to another network approximately simultaneously. The transition may include renumbering all of the IP addresses.
An improved provisioning server that provides a plurality of clients with a plurality of leases created from a database, the improvement comprising at least one customization field associated with each client of the plurality of clients and stored in the database, wherein the provisioning server is operative to modify each lease of the plurality of leases in accordance with each successive customization field of the at least one customization field.
A network management system comprising:
A method of operating a provisioning server to provide a plurality of clients with a plurality of leases created from a database, for each lease of the plurality of leases the method comprising:
A method of operating a provisioning server to transfer a plurality of old leases and an old gateway lease to a plurality of new leases and a new gateway lease respectively, the method comprising:
A method of operating a provisioning server having a plurality of leases on a current network of a plurality of networks, wherein each lease of the plurality of leases has a free state, an active state and an inactive state, for each lease of the plurality of leases the method comprising:
Dependencies are inferred from the claim text.
Drawings are temporarily unavailable. Open the PDF at USPTO
From the US filing history. Foreign family members aren’t listed.
Backward citations are indexed for grants only.
Network arrangements, protocols or services for addressing or naming: address allocation
Network arrangements, protocols or services for addressing or naming
Digital communication
Term end not estimated
1. Field of the Invention
The present invention is related to the field of network provisioning servers.
2. Background Art
FIG. 1 is a hardware block diagram showing a typical network provided by the MSO operator;
FIG. 2 is a software block diagram associated with the hardware block diagram of FIG. 1;
FIG. 3 is a flow diagram of a process that determines the type of network address leased to a client;
An Internet Architecture Board (IAB) defines the Internet standards used below in Standard protocols (STD) and Request For Comments (RFC) documents.
FIG. 1 is a hardware block diagram showing a typical network provided by a Multiple Subscriber Organization (MSO) operator. A Dynamic Host Configuration Protocol (DHCP) (IAB draft standard protocol RFC 2132) server 100 and a Bootstrap Protocol (BOOTP) (IAB draft standard protocol RFC 2131) server 102 are connected to a backbone network 104. Backbone network 104 also provides connections to a Lightweight Directory Access Protocol (LDAP) (IAB proposed standard protocol RFC 2251) server 106, troubleshooting tools 108, IP address management system 110 and a dynamic Domain Name System (DNS) server 112. Other servers not shown may also be found on the backbone network 104, for example a Trivial File Transfer Protocol (TFTP) (IAB standard protocol STD 33) server, communications servers, fire wall servers, directory servers, data servers and the like.
Backbone network 104 may be connected to other networks, network segments, and sub-networks. Two example connections are shown in FIG. 1, to headends 114 and 116. Headend 114 connects to multiple networks, shown as networks 118 and 120. Each network 118 and 120 usually comprise a mixture of fibre optic cables and coaxial cables and their associated hardware. Network 118 connects the headend 114 to multiple cable modems, shown as two cable modems 122 and 124. Network 120 connects the headend 114 to additional cable modems, represented by cable modems 126 and 128. Computers 130-136 access the networks 118 and 120 through the cable modems 122-128. Headend 116 connects to other networks, cable modems and computers (not shown) in another part of the city, or in another city altogether.